Page 1 of 1

Creature Shock on CD-i

Posted: Wed Oct 27, 2010 3:25 pm
by Mcampellone
Has anyone else experienced this? I have Creature Shock burned from original ISO images. The game, when started, and going into the first mission before the space shoot-out freezes, and the only think you can do is click the action button and it takes you straight to the planet to start the alien ship level 2. It totally skips level 1 space shooting. I burned several copies - and still exactly the same. So, I went ahead and I ordered a new original from overseas, which is on it's way now. At first, I thought perhaps this was just a limitation of the player I was on, so I tried it on both 220 models, and the 1100 and also my 370 - all with the same result. Will I expect to see this same bug on the new original set that is arriving, and did I waste my money, or should it be fine? Has anyone else experienced something like this?

I hope you are all having an excellent day - thanks much!


Posted: Wed Oct 27, 2010 7:40 pm
by Jimmy
the shooting sequence has never worked for me on any of my NTSC players. If it does work, my best guess is that it only works on PAL units but I have not tried this yet.

Posted: Wed Oct 27, 2010 7:49 pm
by Mcampellone
Well then I may be out of luck. My 370 is a PAL/NTSC unit, and it's the same on that one - it freezes at the shooting sequence. I just paid a nice amount of money for a new original copy of the game from overseas, so I may have purchased it in haste. If it is going to be the same, it may have been a waste of money then. Oh well... At least it will go nicely in my collection :)

Thank you for your reply! :)

Posted: Thu Oct 28, 2010 12:59 am
by Trev
You could always check out the 3DO or Saturn versions but, imho, Creature Shock is a lousy game regardless of the platform.

I wrote a review for the 3DO version, here is a link from the sister forum ...

Seems like a huge bug/glitch. :?

Btw, does the CD-i version have gun support by chance?

Posted: Sat Nov 06, 2010 11:38 pm
by opt_fr_
I have the original version of CS and I could never play the first shooting) mission. I think it hasn't been implemented in the cd-i version of CS or maybe it is accessible only in hard mode (never tried hard mode)

I stopped playing it because the cd-i crashed at level 3 (screen frozen) and cause my remote is old and it is very hard to play with (when you push the joystick to the left the cursor sometimes goes at right instead of left... :D)