Problems with video and other things...

If you encounter any problems with your CD-i system or have difficulty operating some software for CD-i then post your problems here. With help from the CD-i community and the vast resources hosted on the CDinteractive network we should be able to solve any trouble your experiencing.
Post Reply
Cd-i fan29
Burn:Cycle Activated
Posts: 9
Joined: Thu Feb 01, 2007 7:37 pm

Problems with video and other things...

Post by Cd-i fan29 » Sat Feb 17, 2007 10:13 pm

I recently bought my Cd-i system off Ebay I was very excited about finally owning one. It is a Magnavox 450 model. I also got a "Link: The Faces of Evil", "Zelda: Wand of Gamelon", and "Zelda's Adventure". The games are in perfect condition not a scratch, fingureprint, or anything of that sort.

First thing I noticed was that the system said that I had 100% of its memory used already, but there wasn't any saved data. Later it went back to 0%, but still I thought that was odd.

Next, I put in "Wand of Gamelon", the game started up fine, but I noticed there was no music on the title screen, or the map. I selected new game, and it gave me a "Please clean your disk" error. The game ran just fine than, but whenever I trigered a cutsecene animation I got the error message. Eventually I got an error for loading a level, and I turned it off.

Than, I tried "Faces of Evil". Same thing, I can play the game, but the cutsecene animation gives me an error, and there was no music on the title screen, or the map. I was confused at why both games would do that. I took the disk out and looked at both. Both were in perfect condition and cleaning didn't do anything.

I went to try "Zelda's Adventure", but the system wouldn't even go to the systems screen, where you can select the options! I took the game out, and unpluged and repluged everything. I tried to turn the system on without the game, nothing again, just a black screen. I unplugged and replugged several times also.

Finally, I unplugged everything again waited 5 minutes, and repluged and I got the system to go to it's main screen. I then loaded "Zelda's adventure" in, and the system got to the title screen. I selected new game, and the screen went black and never did anything. :(

I than, tried all the games again several times, and I got the same thing evertime. "Faces of Evil" and "Wand of Gamelon" play fine, but I get a "Please clean your disk" error evertime a cutsence comes up. And Zelda's Adventure never makes it past the title screen.

Please help me. Is the system bad? If so can I fix it, or do I have to send it back and buy a different one?

Thank you,

User avatar
CDinteractive Admin
Posts: 3041
Joined: Mon Jun 20, 2005 11:14 am
Location: the Netherlands

Post by Bas » Sat Feb 17, 2007 10:19 pm

In short, your descriptions sound like the timekeeper battery is empty. It's the same thing as the other new thread is about. Search the forum for "timekeeper battery" and you'll find a few topics about this.

Post Reply